Abel thanks for your suggestion. Unfortunately the condition has to be a sequence. Since it is immutable I could make it a tuple instead of a list but that would look like:
condition = (Packaging.distroseries == self.id, )
which I personally to be more distracting than just using a list. So unless you have strong objections I'd prefer to leave the code as is.
Abel thanks for your suggestion. Unfortunately the condition has to be a sequence. Since it is immutable I could make it a tuple instead of a list but that would look like:
condition = (Packaging. distroseries == self.id, )
which I personally to be more distracting than just using a list. So unless you have strong objections I'd prefer to leave the code as is.