Merge lp://qastaging/~canonical-isd-qa/selenium-simple-test/tables into lp://qastaging/selenium-simple-test

Proposed by Michael Foord
Status: Merged
Approved by: Corey Goldberg
Approved revision: 257
Merged at revision: 250
Proposed branch: lp://qastaging/~canonical-isd-qa/selenium-simple-test/tables
Merge into: lp://qastaging/selenium-simple-test
Prerequisite: lp://qastaging/~canonical-isd-qa/selenium-simple-test/goto-start
Diff against target: 290 lines (+198/-8)
8 files modified
.bzrignore (+1/-0)
src/sst/actions.py (+98/-3)
src/sst/selftests/assert_element.py (+6/-3)
src/sst/selftests/attribute.py (+11/-0)
src/sst/selftests/tables.py (+40/-0)
src/testproject/simple/views.py (+4/-1)
src/testproject/templates/tables.html (+36/-0)
src/testproject/urls.py (+2/-1)
To merge this branch: bzr merge lp://qastaging/~canonical-isd-qa/selenium-simple-test/tables
Reviewer Review Type Date Requested Status
Corey Goldberg (community) Approve
Review via email: mp+88695@code.qastaging.launchpad.net

This proposal supersedes a proposal from 2012-01-16.

Commit message

Add assert_attribute, assert_table_row_contains_text, assert_table_headers and assert_table_has_rows actions.

Description of the change

Add assert_attribute, assert_table_row_contains_text, assert_table_headers and assert_table_has_rows actions.

To post a comment you must log in.
252. By Michael Foord

Stub implementation of assert_table_row_contains

253. By Michael Foord

Implementation of assert_table_row_contains

Revision history for this message
Michael Foord (mfoord) wrote :

What do you think about these action names?

Currently the actions that act on table rows require the rows to be in a <tbody> so we don't have any ambiguity between header rows and normal rows. This is fine for our (current) internal requirements - maybe relax the restriction if we have complaints? (With the added complexity that relaxing the restriction brings.)

Revision history for this message
Michael Foord (mfoord) wrote :

I renamed assert_table_row_contains to assert_table_row_contains_text, because it is only asserting about text contents. I also added a regex parameter.

254. By Michael Foord

Rename assert_table_row_contains to assert_table_row_contains_text and add regex parameter

255. By Michael Foord

Update action docstring

256. By Michael Foord

Adding assert_attribute action

Revision history for this message
Michael Foord (mfoord) wrote :

I needed to add assert_attribute to check that elements of a form are not disabled. If the disabled attribute is not set then assert_element('id', disabled='false') and variants *fail*. You have to fetch the element and then assert about the disabled attribute afterwards.

257. By Michael Foord

Fix for assert_table_row_contains_text where row is wrong length

Revision history for this message
Corey Goldberg (coreygoldberg) wrote :

tests pass and action names seem good.
lgtm.

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
The diff is not available at this time. You can reload the page or download it.

Subscribers

People subscribed via source and target branches