Code review comment for lp://qastaging/~andreagrandi/unity-2d/main

Revision history for this message
Ugo Riboni (uriboni) wrote :

All fixes are good, thanks for taking the time to do them.
There's just a few things missing:

68 + Trash* _this = static_cast<Trash*>(data);
69 +
70 + switch (event_type)
71 + {
72 + case (G_FILE_MONITOR_EVENT_DELETED || G_FILE_MONITOR_EVENT_CREATED):
73 + return _this->fileChanged();
74 + break;
75 + default: ;
76 + }

Please rename "_this" to "instance", and instead of the switch/case use a simpler and shorter if statement.

After you fix that, I will approve it and it will be merged into the trunk.

review: Needs Fixing

« Back to merge proposal