Merge lp://qastaging/~mhr3/unity-lens-files/fix-921665 into lp://qastaging/unity-lens-files

Proposed by Michal Hruby
Status: Merged
Approved by: Mikkel Kamstrup Erlandsen
Approved revision: 215
Merged at revision: 216
Proposed branch: lp://qastaging/~mhr3/unity-lens-files/fix-921665
Merge into: lp://qastaging/unity-lens-files
Diff against target: 184 lines (+57/-26)
2 files modified
src/daemon.vala (+56/-25)
src/folder.vala (+1/-1)
To merge this branch: bzr merge lp://qastaging/~mhr3/unity-lens-files/fix-921665
Reviewer Review Type Date Requested Status
Mikkel Kamstrup Erlandsen (community) Approve
Review via email: mp+95865@code.qastaging.launchpad.net

Description of the change

Fix activation of bookmark URIs. Standard URIs now also fall through so unity will activate them (that way they're launched using proper AppLaunchContext).

To post a comment you must log in.
214. By Michal Hruby

Make sure folders are not duplicated

Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

did know you could do 'if (flag in flags)' in Vala. That is crazy cool :-)

7 Unity.FilesLens.append_events_sorted (results, results_model,
8 - 0, int64.MAX, false,
9 - category_id);
10 + 0, int64.MAX, 0,
11 + null, category_id);

Can you use ResultFlags.NONE instead of 0 to improve legibility here?

80 + private const string ATTR_TYPE_AND_HIDDEN = FILE_ATTRIBUTE_STANDARD_TYPE +
81 + "," + FILE_ATTRIBUTE_STANDARD_IS_HIDDEN;
82 + private const string ATTR_SIZE_AND_HIDDEN = FILE_ATTRIBUTE_STANDARD_TYPE +
83 + "," + FILE_ATTRIBUTE_STANDARD_SIZE +
84 + "," + FILE_ATTRIBUTE_STANDARD_IS_HIDDEN;

I think you should change the name of ATTR_SIZE_AND_HIDDEN since it's slightly misleading (excluding the TYPE). Maybe just ATTR_TYPE_HIDDEN and ATTR_TYPE_HIDDEN_SIZE?

Otherwise looking great!

review: Needs Fixing
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

s/did know/did not know/

215. By Michal Hruby

Improve readability

Revision history for this message
Michal Hruby (mhr3) wrote :

And pushed!

Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

And liking!

review: Approve

Preview Diff

[H/L] Next/Prev Comment, [J/K] Next/Prev File, [N/P] Next/Prev Hunk
The diff is not available at this time. You can reload the page or download it.

Subscribers

People subscribed via source and target branches