Code review comment for lp://qastaging/~mhr3/unity-lens-files/fix-921665

Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

did know you could do 'if (flag in flags)' in Vala. That is crazy cool :-)

7 Unity.FilesLens.append_events_sorted (results, results_model,
8 - 0, int64.MAX, false,
9 - category_id);
10 + 0, int64.MAX, 0,
11 + null, category_id);

Can you use ResultFlags.NONE instead of 0 to improve legibility here?

80 + private const string ATTR_TYPE_AND_HIDDEN = FILE_ATTRIBUTE_STANDARD_TYPE +
81 + "," + FILE_ATTRIBUTE_STANDARD_IS_HIDDEN;
82 + private const string ATTR_SIZE_AND_HIDDEN = FILE_ATTRIBUTE_STANDARD_TYPE +
83 + "," + FILE_ATTRIBUTE_STANDARD_SIZE +
84 + "," + FILE_ATTRIBUTE_STANDARD_IS_HIDDEN;

I think you should change the name of ATTR_SIZE_AND_HIDDEN since it's slightly misleading (excluding the TYPE). Maybe just ATTR_TYPE_HIDDEN and ATTR_TYPE_HIDDEN_SIZE?

Otherwise looking great!

review: Needs Fixing

« Back to merge proposal