Code review comment for lp://qastaging/~thisfred/desktopcouch/remove-recordtype-from-dict

Revision history for this message
Eric Casteleijn (thisfred) wrote :

> - since you don't need current_value anymore here:
>
> - for index, current_value in enumerate(self):
> + for index, _ in enumerate(self):
>
> you might as well write:
>
> for index in range(len(self)):

Yeah that's better

> Also, what's with the double blank lines before or after functions and
> methods? You only need double between classes. Don't get overboard with that
> automatic pep8 thing. ;-)

Actually I like having two lines between top level definitions no matter what they are (so functions or Classes, *not* methods.) It makes me have to think less, and improves readability. Also a top level function and a class definition are rather similar things IMO.

« Back to merge proposal